Silverlight Compatible Browsers and Operating Systems  

To see a table of compatible browsers and operating systems, select your version of Silverlight below (or click here to go to Microsoft's Silverlight Homepage and select Silverlight-compatible operating systems):

Note: Currently, only version 4 of Silverlight will run in Google Chrome on a Mac OS X; and only version 5 of Silverlight will run in a 64-bit version of Internet Explorer.


Microsoft Silverlight 5.0 Compatible Browsers and Operating Systems  

Browser & Version

Operating System

Internet Explorer

Firefox

Safari

Chrome

11

10

9

8

12 +

4 + 

12 + 

Windows OS

 

  

 

 

 

8.1 Desktop

Yes*              

8 Desktop

  Yes*

Yes

Yes

Server 2012

  Yes*

Yes

Yes

7

 

Yes 

Yes 

 

Yes

Yes 

7 SP1

Yes* Yes*

Yes 

 

Yes

Yes 

Vista

 

Yes

Yes

Yes

Yes

Yes

XP w/ SP2 or SP3

 

 

Yes

Yes

Yes

Yes

Server 2008 R2 SP1

 

Yes*

Yes*

 

 Yes

Yes

Server 2008 SP2

 

Yes

Yes

Yes

Server 2003 

 

 

Yes

Yes

Yes

Yes

 * = Supports 64-bit mode

 

 

 

 

 

 

 

 

 

 

 

 

 

Mac OS 10.5.7+

 

 

 

 

 

 

 

Intel-based

 

 

 

 

 

Yes

Yes

 

 

 

 

 

 

 

 

 

 

Minimal Computer Requirements

 Personal Computer: Windows x86 or x64 (*64-bit mode support in IE only) 1.6-GHz or higher processor with 512-MB of RAM 

 Mac (Intel-based): Intel Core Duo 1.83-GHz or higher processor with 512-MB of RAM.  

Microsoft Support: "Silverlight 5 will support the browser versions listed on this page through 10/12/2021, or though the support lifecycle of the underlying browsers, whichever is shorter..."

Primary Source: http://www.microsoft.com/getsilverlight/locale/en-us/html/installation-win-SL5.html   

Return or go to Fix Silverlight Issues on CTI's "Instructions to Fix Errors or Troubleshoot Problems When Using CTI Navigator" website.

Back to Top of this web page


Microsoft Silverlight 4.0 Compatible Browsers and Operating Systems

Browser* & Version 

Operating System

Internet Explorer

Firefox

Safari

Chrome

9 +

8

3.6 +

4 + 

4 + 

Windows OS

 

   

 

 

 

7

Yes

Yes

 

 

Yes

 

Yes

7 SP1

Yes

Yes

 

 

Yes

 

Yes

Vista 

Yes

Yes

Yes

 

Yes

Yes

XP w/ SP2 or SP3 

 

Yes

Yes

(Yes)

Yes

 

Yes

Server 2008 R2 SP1

Yes

Yes

Yes

 

Yes

 

Yes

Server 2008 SP2

Yes

 

Yes

 

Yes

Server 2003 

  

Yes

Yes

(Yes)

Yes

 

Yes

2000 SP4+  

 

 

 

(Yes) 

Yes

 

 

 

  

 

 

 

 

 

 

Mac OS 10.4.11+ 

 

 

 

 

 

 

Intel-based 

 

 

 

 

Yes

Yes

  (Yes)

 

  

 

 

 

 

 

Linux or Unix/X11 OS (uncertain)

 

 

 

 

Moonlight

 

  Moonlight

  

  

 

 

 

 

 

 

*All browsers in 32-bit mode

Minimal Computer Requirements

 Personal Computer: Windows x86 or x64 (browser must be in 32-bit mode) 1.6-GHz or higher processor with 512-MB of RAM

 Mac (Intel-based): Intel Core Duo 1.83-GHz or higher processor with 512-MB of RAM

 Linux (SUSE Linux Enterprise Desktop 11, openSUSE 11.x, Ubuntu 9.10, and Fedora 12): x86 or x86-64 computer with at least 512-MB of RAM using Moonlight (http://www.go-mono.com/moonlight) and Firefox 3.0 through 4.x, or Google Chrome.   

Primary Source:  http://www.microsoft.com/getsilverlight/locale/en-us/html/installation-win-SL4.html

To download Silverlight for Mac OSX (32-bit), you can go to http://go.microsoft.com/fwlink/?LinkId=229322 .

Return or go to Fix Silverlight Issues .

Compatibility Add-on for Chrome or Firefox

There is a free browser extension called "IE Tab" that runs Windows Internet Explorer (IE) components within a tab in Chrome or Firefox. This enables you to display web pages that use Silverlight (such as CTI Navigator Web) within your Chrome or Firefox browser, even if the browser itself does not correctly load Silverlight. The IE Tab also includes an "Auto URL" filter and a Bookmarks feature that allow you to specify which URLs should always be loaded with IE Tab. 

Even though it does not open the IE browser per se, IE Tab uses the IE Browser Control core engine. Therefore, to ensure full security when using IE Tab, the latest version of Internet Explorer should be installed on your computer and it should be kept up-to-date with the latest security patches from Microsoft.

You can read about and download IE Tab at www.ietab.net

Back to Top of this web page 


Related articles and Internet links: 

{rev 11.01.2013}