Fix Display of Linked PDF Files on the Web

Many factors can affect the display of a document in PDF format on the web. This problem can appear as:

Some of the causes for PDF display problems in an Internet browser include:

Progressively click on the following topics as appropriate for instructions on possible solutions

Index of Possible Solutions to PDF Display Problems

To see video instructions for the most common fixes, go to https://www.youtube.com/watch?v=_ufMfbRYB_8 .

Click here for instructions to Fix PDF Print from Browser problems


Activate Adobe End User License Agreement

  1. Close Acrobat Reader and open Windows File Explorer
  2. Browser to C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader (or older version 11 at C:\Program Files (x86)\Adobe\Reader 11.0\Reader)
  3. Double-click to run the “Eula.exe” file and accept Adobe’s license agreement.

Disable Protected Mode at Startup (using Sandbox restrictions)

  1. Open Adobe Acrobat Reader DC
  2. Click “Edit” and select Preferences in the top menu
  3. Click on “Security (Enhanced)” on the left pane
    (click on image to enlarge)
  4. Un-check “Enable Protected Mode at startup”
  5. Leave "Enable Enhanced Security" checked and click OK
  6. Click “Help” in Adobe Reader’s top menu and select “Repair Installation”
  7. After Repair completes, then click on “Check for Updates

See “How to Fix PDF Reader Not Working In Windows 10/8.1/7 (Acrobat Reader DC) ” for video instructions.

Restore Browser Settings

To restore the default tabbed browsing settings that control how pop-ups and links from other programs are displayed in Internet Explorer:

  1. Close all browser screens and try again. 
  2. In Internet Explorer's browser menu, select Tools (or the gear icon), and then Internet Options.
  3. In the Tabs section, click the Tabs button in IE 10 and 11 (Settings button in IE 9 and earlier).  
  4. On the Tabbed Browsing Settings screen, click the "Restore Defaults" button.
  5. Under "When a pop-up is encountered", select "Always open Pop-ups in a new window."
  6. Click OK and try again.

Reset Internet Explorer (11, 10, 9, 8 or 7)

Internet Explorer may fail to function properly after being upgraded, after free browser add-ons (such as animations, extra search toolbars, dictionary/translator/thesaurus, pop-up blocker, weather/stock tracker, etc) have been installed, after installing (or uninstalling) a different browser (such as Google Chrome), or after running a "registry cleaner" or similar program. Free registry cleans are risky because they can delete important files.

While they sound useful, free browser add-ons can hijack or block the browser's normal links so they can direct you to ad supported links (like most freeware). You  may need to uninstall the offending free add-ons and free toolbars (such as Ask.com, Crawler, InfoAtomsFunWebProducts, MyWebSearch, MySearch, My Way Speedbar, Search Assistant) or desktop gadget adware (such as WeatherBug or WhenU) to allow linked documents to display properly. 

If a browser error such as "Internet Explorer has stopped working..." is displayed, you may need to reset Internet Explorer.

To reset Internet Explorer back to its original default settings (see warning note below) you can either click here to run the Microsoft's "Fix it" utility, or you can follow the instructions below:

  1. Start Internet Explorer (if possible) and select the Tools menu. If Internet Explorer fails, open the Windows Control Panel.
  2. Click on Internet Options
  3. Select the Advanced tab
  4. Click the Reset button
  5. In the "Reset Internet Explorer Settings" dialog box, click Reset to confirm.
  6. You may need to re-start Windows for all changes to take effect. 

For details, see Microsoft's article "How to reset Internet Explorer settings". 

Warning Note

▲ Back to the Solutions INDEX at the Top of this web page

Delete Temporary Internet files in Internet Explorer

  1. In Internet Explorer's browser menu, select Tools (or the gear icon), and then Internet Options.
  2. In the Browsing History area of the General tab, click the Delete button. 

     

  3. Check all boxes (especially "Temporary Internet Files" and Cookies), and then click Delete. (For information about the options, click "About deleting browsing history" beside the Delete button on this screen.)   

     
  4. Click OK when prompted, and then click OK to close Internet Options.

Note. If you seldom or never clear your browsing history, this could take several minutes.

▲ Back to the Solutions INDEX at the Top of this web page

Clear History in Microsoft Edge

  1. Click on the Hub icon
  2. Select the History icon
  3. On the History screen either click "Clear All History" at the top, or click the "X" beside a previous time period from which to clear data.

Clear Recent History files in Firefox (Windows & Mac)

  1. In Firefox, click Tools and select Clear Recent History (or "Clear Private Data" in older versions). 
  2. Click the drop-down arrow and select the "Time Range" to clear
  3. Select Everything to clear all files in the cache
  4. Click the Details button to choose what history elements to clear
  5. Select "Browsing & Download History", Cookies, and Cache 
  6. Click the "Clear Now" button. 
  7. Exit and re-launch the Firefox browser. 

Reset Safari History (Mac OS X)

  1. Click the word Safari in the browser's top menu
  2. Select "Clear History..."
  3. Select the time period (such as last hour, today, or all) for which to clear history
  4. Click the "Clear History" button
  5. Exit and re-launch the Safari browser.

Clear Google Chrome Browsing Data (Windows & Mac OS X)

  1. Click on Chrome's menu icon Chrome Menu icon
  2. Select "More Tools"
  3. Select "Clear Browsing Data"
  4. Click the button beside "Clear the following items from..." and select the appropriate time period (such as past hour, day, week, or the beginning of time)
  5. Check "Browsing History", "Cached images and files", "Cookies...", and any other type of information that you want to remove
  6. Click the "Clear Browsing Data" button
  7. Close all Chrome screens, and then re-start Chrome.

Delete Opera Private Data (Windows & Mac OS X)

  1. Open Opera
  2. Click Tools and select Delete Private Data.
  3. Expand Delete Options and choose what history elements to clear.
      - e.g. Delete temporary cookies, Delete all cookies, Delete entire cache.
  4. Click the Clear Now (Opera 9) or Delete (Opera 10) button.
  5. Close window.
  6. Exit and re-launch the Opera browser.

▲ Back to the Solutions INDEX at the Top of this web page

Set CTIMLS.com as a Trusted Site in Windows

To set ctimls.com as a "trusted site" in Windows Control Panel (or Internet Explorer's Tools/gear icon):
  1. Select Internet Options
  2. Click the Security tab > select Trusted Sites > click Sites button > un-check "Require server verification (https:)... " > click in the "Add this website to the zone" box and type ctimls.com > click the Add button > click the close button. 
  3. Click the Privacy tab:
    1. Click the Sites... (or Edit) button > in "Address of Web Site" box type ctimls.com > click Allow button > click OK button.
    2. Click the Advanced button (not Advanced tab) > check "Override automatic cookie handling" > click "Always allow session cookies > leave "First-party cookies" selected as "Accept" > {Third -party cookies can be Accept, Block, or Prompt} > click OK button.
    3. If available, check "Block Popups"> click the Settings button >  in the "Address of Site to Allow" box type ctimls.com > click Add button > click Close button > click OK button on Privacy tab screen. {see note below}
  4. Click the Connections tab
    1. If your Internet connection is broadband (DSL, cable or fiber-optic), click the LAN Settings button. If your Internet connection is dial-up, click the Settings button (beneath the Remove... button).
    2. Clear (un-check) all boxes under Automatic Configuration
    3. Clear (un-check) all boxes under Proxy Service > click OK.
  5. If you have enabled the Content Advisor in Internet Options, click the Content tab 
    1. In the Content Advisor section, click Settings
    2. Click the Approved Sites tab
    3. In the "Allow this Web site" box type ctimls.com
    4. Click the Always button and then click OK.

Note. Pop-up settings can be configured from Internet Options as described in step 3-C above. Pop-up settings also can be configured in Internet Explorer by selecting Tools (or gear icon) > Pop-up Blocker > Pop-up Blocker Settings > in "Address of website to allow" enter ctimls.com > click the Add button. 

▲ Back to the Solutions INDEX at the Top of this web page

Verify or Set Adobe Enhanced Security to use Windows Trusted Sites

To ensure that the Enhanced Security in Adobe Reader or Acrobat is using Windows Trusted Sites:

  1. Open a PDF document window in your browser. (It doesn't matter if the document itself is displayed. However, you can paste the URL path to a PDF document in your browser's address bar if the link to the document fails to automatically open the document.)
  2. Right-click anywhere inside the document window and select "Page Display Preferences"
  3. In the Categories list on the left pane, select "Security (Enhanced)"
  4. Ensure that "Enable Enhanced Security" is checked at the top
  5. Under Privileged Locations, ensure that "Automatically trust sites in my Win OS security zones" is checked
  6. Option: you also can click the "Add Host" button, enter ctimls.com, and click OK
  7. Click OK to close the Page Display Preferences screen. 

Repair Adobe Reader or Acrobat Installation

If PDF files do not open correctly, even directly in Reader or Acrobat:
  1. Open Adobe Reader or Acrobat, click Help in the menu and select "Repair Installation".
  2. If Adobe's internal Repair fails to correct the problem, close Adobe Reader or Acrobat and open Windows Control Panel
  3. Open Windows Add/Remove programs:
  4. Click Change/Repair and follow the instructions to repair the application
  5. When the repair completes, click Finish. 
  6. If repair does not resolve the problem, uninstall and then re-install Adobe Reader (see below).

Uninstall and re-install Adobe Reader

  1. Run Adobe’s Cleaner Tool at http://labs.adobe.com/downloads/acrobatcleaner.html 
  2. Download and re-install a fresh copy of Adobe Reader (see "Install Reader or Acrobat" or go directly to https://get.adobe.com/reader/).

▲ Back to the Solutions INDEX at the Top of this web page

Enable the Adobe PDF browser Plug-in

Internet Explorer (Windows)  

The steps to enable the Adobe PDF plug-in (AdobePDF.dll) vary depending on your version of Internet Explorer. 

  1. Select Tools > Manage Add-ons. (Or choose Tools > Internet Options, click the Programs tab, then click Manage Add-ons.)
  2. In the "Show" pop-up menu (at the lower left of the screen), select All Add-ons. (Or select "Add-ons That Have Been Used by Internet Explorer")
  3. Scroll to the section of add-ons for Adobe Systems, and select Adobe PDF Reader.
  4. If the status of Adobe PDF Reader is set to Disabled, click the Enable button.
  5. If Adobe PDF Reader is not listed, install the latest version

Firefox (Windows)

  1. Select Tools > Options
  2. Click the General tab, then click Manage Add-ons

      (click on image to enlarge if desired)
     
  3. Click the Plug-ins tab. (The layout of this dialog box differs depending on the version.)

          (click on image to enlarge if desired)
     
  4. Find and select Acrobat or Adobe Reader:
  5. If the Adobe PDF Plug-in is not listed, install the latest version of Reader or Acrobat.

Chrome 

To set Chrome to use the Adobe PDF plug-in (with its more extensive tools) instead of Chrome's PDF Viewer by default:

  1. Open the Chrome browser 
  2. Click to open a New Tab (or press Ctrl+T on the keyboard)
  3. In the omnibox at the top, type  about:plugins  (or chrome:plugins ) and press the enter key
  4. Scroll down and immediately beneath "Chrome PDF Viewer" click on Disable
  5. Scroll down to "Adobe Reader" and immediately beneath click Enable 
  6. Close the Plug-ins tab.

▲ Back to the Solutions INDEX at the Top of this web page

Safari (Mac OS X)

Safari 7.0 (in Mavericks OS X 10.9) on Mac

To set Safari 7 to trust the Adobe Reader plug-in to run on all websites:

  1. Open Safari
  2. Click "Safari" in the top-left next to the Apple icon
  3. Under Safari select Preferences
  4. Select the Security icon at the top
  5. Click on the "Manage Website Settings" button
  6. Click on "Adobe Reader" in the list of available plug-ins on the left
  7. On the right pane, select "Allow" beside all "Configured Websites" listed (if any)
  8. In the lower-right corner, beside “When visiting Other sites”, select "Allow Always"
    • Select "Allow" or “Allow Always” only if you intend for all websites to be allowed to use the selected plug-in (which is not necessary for CTI Navigator)
    • Do not select “Run in Unsafe Mode” for "other websites" because you might inadvertently visit some other (non-CTI) website that injects malicious code or malware through plug-ins.
  9. Click Done.

For instructions and screen shots on how to set Safari 7 to trust the Adobe Reader plug-in specifically for FAR's Forms Simplicity website, click here or select "Activating the Adobe Reader Plug-in for Safari 7.0 Mavericks MAC OS 10.9 " in the Related Articles at the end of this web page.

Safari 5.1 Workarounds (per Adobe)

Adobe Reader plug-in and Acrobat plug-in versions before 10.1.3 are not compatible with the Safari 5.1 browser included with Mac OS X 10.7 and 10.6. The Adobe Reader and Acrobat standalone applications are unaffected and Safari 5.1 renders PDF documents natively. However, the Adobe Reader and Acrobat browser plug-ins will not function properly for document links that require either plug-in to render PDF documents in Safari 5.1.

Options include the following: 

For more information and possible updates, see Apple Safari 5.1 and Adobe Reader/Acrobat Advisory

Safari 5.0.x

The AdobePDFViewer plug-in used by Acrobat and Reader to display PDF files in Safari (5.0 and earlier) on a Mac is installed in 

/Library/Internet Plug-ins/AdobePDFViewer.plugin .

To disable/remove the Adobe plug-in in Safari on a Mac, close Safari, use the Finder to go to the Internet Plug-ins Library, and drag the AdobePDFViewer.plugin file to the Trash. To save the plug-in for possible use later, you can create a folder called "Disabled Plug-ins" in your home directory, and then drag this file to that folder.  Then, to reinstall the plug-in, just drag the file back to its original location. Otherwise, to re-install the Adobe plug-in, re-install Adobe Reader or Acrobat over the current installation.

After you remove a plug-in by moving it to the Trash or another folder, you must restart Safari for the change to take effect.

▲ Back to the Solutions INDEX at the Top of this web page

Verify or Reset the "Display PDF in Browser" Preference

To ensure that Adobe Reader or Acrobat are set to display PDF files in your browser:

  1. Open a PDF document window in your browser. (It doesn't matter if the document itself is displayed. However, you can paste the URL path to a PDF document in your browser's address bar if the link to the document fails to automatically open the document.)
  2. Right-click anywhere inside the document window and select "Page Display Preferences"
  3. In the Categories list on the left pane, select Internet
  4. Check "Display PDF in browser"
  5. Click OK to close the Page Display Preferences screen. 

Update Reader or Acrobat 

Adobe releases regular security updates for Reader and Acrobat. To update an existing installation:

  1. Open the Reader and Acrobat program on your computer (not on the Internet)
  2. Click on  Help in the top menu
  3. Select "Check for Updates"
  4. Otherwise you can check for updates at  www.adobe.com/support/downloads

Remove Multiple Versions of Reader or Acrobat 

Adobe doesn't support multiple versions of Reader or Acrobat on the same computer. Multiple versions simultaneously installed can lead to software conflicts and errors. If you are experiencing a problem viewing PDF files, uninstall all versions of Reader or Acrobat and then reinstall only one version of the product. See "Install the Latest Version of Reader or Acrobat" for links to use to download Adobe.  

Install the Latest Version of Reader or Acrobat

Adobe recommends to always use the latest version of Reader or Acrobat. You can download the free Reader for Windows at 

Get the free Adobe Reader update or full installer for Macintosh at http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Macintosh 

Before you install an update or upgrade, make sure that your system meets the minimum system requirements:

Notes

▲ Back to the Solutions INDEX at the Top of this web page

View PDF in a 32-bit version of Internet Explorer

Acrobat and Reader are 32-bit applications on Windows. If you try to open a PDF in a 64-bit version of Internet Explorer, the PDF opens in stand-alone Acrobat or Reader, not in Internet Explorer.

Note: Only Reader 10.1 or Acrobat 10.1 and later support Internet Explorer 9 and later.

To make sure that you are using a 32-bit version of Internet Explorer, follow these steps:

  1. In Internet Explorer, choose Help > About Internet Explorer. (In some versions of Internet Explorer, select the Question mark icon in the upper-right corner to select About Internet Explorer).
     
  2. If you do not see the words "64-bit Edition" next to the version, then you are running a 32-bit version of Internet Explorer.  
             (click on image to enlarge if desired)

Note: For a list of browsers that can display Adobe PDF files using Reader or Acrobat X, see the "Acrobat PDF-capable web browsers" section in Compatible web browsers and PDFMaker applications | Acrobat, Reader.

Configure Acrobat or Reader as a Helper application

With Acrobat or Reader configured as a helper application, the browser starts the helper application in a separate window and displays PDFs within that window.

  1. Start the Acrobat or Reader program 
  2. Choose Edit > Preferences
  3. Select Internet on the left
  4. Un-select " Display PDF In Browser Using [Acrobat application]", and then click OK
  5. Close Acrobat or Reader.

Acrobat PDF Compatible Web Browsers

The following browsers can display PDF files using Acrobat Reader X or DC () products as specified (see note 4 for Adobe's most current list):

Operating System Internet Explorer Firefox Safari Google Chrome
Windows 7, 8; 9 (10.1 only), 10, 11.0 3.6;  4 and 5.0.1 (10.1 only), 6 (10.1.1 only); ESR  10.1.x and 11.0.x N/A √ (10.1) and 11.0.x
Mac OS X (10.5.8 & later) N/A  ESR 4, 5.0.3;  5.0.5 (10.1.1 only; 5.1.x (10.1.2 & ater); 6.0.x (11.0.0 & later) N/A 

Notes:  

  1. The Adobe Reader plug-in version 10.1.2 and earlier, and Adobe Acrobat plug-in version 10.1.2 and earlier are not compatible with the Safari 5.1 browser. For more information, see Apple Safari 5.1 and Adobe Reader/Acrobat Advisory.

  2. The Adobe Reader 10.1.5 and later plug-in, and the Adobe Acrobat 10.1.5 plug-in and later plug-in do not function in the Macintosh Mozilla Firefox 19 and later.  Use the ESR (Extended Support Release) version of the Mozilla Firefox web browser for larger organizations.

  3. For Adobe's current list of browsers that can display Adobe PDF files using Reader or Acrobat X, see the "Acrobat PDF-capable web browsers" section in Compatible web browsers and PDFMaker applications | Acrobat, Reader.  

▲ Back to the Solutions INDEX at the Top of this web page


Related Articles and Source Documents from Adobe


To return to the Solutions Index at the top of this web page, click here.

To return to CTI's menu of Error Fixes, click here or use the back arrow at the top of your Internet browser.

To go directly to CTI's menu of Help and Tutorials, click here.

 

rev. 11.17.2017