Internet Browser Issues

Click on the appropriate topic in the index below to go directly to information relevant to that topic.

Internet Explorer 

Firefox

Chrome

Safari

Browser Errors in Windows

Related Articles and Internet Links, such as: 


Internet Explorer Issues

Delete Browsing History

If returning to a previously visited website (such as CTI Navigator Web) fails or new entries at a website do not function properly, the problem could be a corrupted file in the browser's history. These files are saved as temporary Internet files for convenience (to improve browsing speed and to save having to type the same information over and over), and can all be deleted. (See also note 3 below if CTI Navigator Web fails to display the sign-in screen.)

To automatically delete IE's browsing history:

  1. Open Internet Options (in Windows Control Panel, or in IE under Tools, or click the Safety icon)
  2. Under the General tab, click the Delete button in the Browsing History section
  3. Un-check "Preserve Favorites Website Data"
  4. Check all other boxes (or, at a minimum, check Temporary Internet Files, and Cookies)
  5. Click the Delete button. This could take awhile if you have a lot of files and history stored
  6. After deletion completes, click OK to close the Internet Options window. 

Note 1

If using the delete button in the Internet Options Browsing history (as described above) does not resolve the problem, you can manually delete Temporary Internet Files as follows: 

  1. Open Internet Options (or see the note 2 below) 
  2. Under the General tab, click the Settings button in the Browsing History section 
  3. Click the View Files button 
  4. Highlight the Temporary Internet Files folder
  5. Click Edit > Select All > Delete.

Note 2. You also can browse in Windows Explorer to the Temporary Internet Files folder and delete its files. Usually this folder is under C:\Documents and Settings\{Your Name}\ Local Settings\ . 

Reset IE. If your Internet Explorer has become unstable (repeatedly shuts itself down or fails to function properly), you can reset it.  A Reset will delete all settings that have changed since Internet Explorer was first installed, including browsing history. See the Reset Internet Explorer to defaults section below for instructions to reset IE. 

Note 3: CTI Navigator Web needs the Silverlight browser plug-in to run in your browser. If the website fails to display the sign-in screen for CTI Navigator Web, ensure that your browser's history has been cleared (select for your browser in the index at the top of this web page) and that Silverlight is properly installed to run in your browser (select for your browser in the index at the top of this web page). For detail instructions on installing and fixing Silverlight, click "Fix Silverlight Issues" in the index or in the Related Articles.   

▲ Back to the top of this web page 

Web-Links or Virtual Tour Links

When web-links or Virtual Tour web pages from CTI Navigator do not display in your Internet browser and do not display an error message, it usually is because a pop-up-blocker is preventing the display. To unblock the display, configure or disable your pop-up-blocker for the web address of the web link or virtual tour. For instructions on managing pop-up blockers, see "Disable or Configure Common Pop-Up Blockers or Remove Add-on Toolbars" in the related articles at the end of this web page. See the section below on this web page for how to allow desired Pop-Ups

If an error message displays when you click on a Web-Link, see the "Display Web Links" section below; or select that error message in the Errors section of this webpage, or select that error message on CTI's Instructions to Fix Errors webpage to see instructions specific to that error. 

▲ Back to the top of this web page 

Display Allowed Pop-ups

Your browser can be set to display pop-ups that appear as a result of you clicking on a link or button, or automatic pop-ups from trusted sites in either a new Window or in a new Tab. The default setting normally is to open in a new Window.  

To specify how to display allowed pop-ups in Internet Explorer, click Internet Options. On the General tab, click the Settings button in the Tab section ("Change how web pages are displayed in tabs"). Then check your preference under "When a pop-up is encountered". The default is "Always open pop-ups in a new window." There is a button you can click to "Restore defaults." 

Display Web Links

Sometimes Internet Explorer fails to open a new Tab or new Window in which to display a linked website. An error may or may not display. This can be caused by missing or corrupted registration of some Internet Explorer system libraries (dll files) - especially in Windows 7.  

To re-register the original Internet Explorer (IE) files from Microsoft, close all browser pages and click on the link below appropriate for your version of Windows and your version of Internet Explorer. 

In Windows Vista or Windows 7, first save the file to your computer. Then right-click on any ".bat" file or any "cmd" file after unzipping, and choose "Run as Administrator." 

In Windows XP, you can open/run or save the file. Then unzip the file and double-click on any cmd file or any .bat file.

Close the black screen after the file runs. 

If this does not resolve the problem, follow the appropriate instructions below to reset your version of Internet Explorer . This should also reset Internet connectivity components in Windows, regardless of which browser is set as the default. (See the warning note before re-setting Internet Explorer.)

▲ Back to the top of this web page 

Website Compatibility 

When Internet Explorer 8 or 9 does not properly display web pages or HTML links, you can set it to allow content designed for previous versions by using the "Compatibility View" as follows:

  1. Open Internet Explorer
  2. Click on Tools at the top (or in IE-9 click )
  3. Select "Compatibility View Settings" (displayed below)
  4.  
  5. Set Compatibility by either  
  6. Click the Close button.

▲ Back to the top of this web page

IE 9 64-bit Incompatibility 

As of winter 2011, the 64-bit Edition of Internet Explorer 9 is not compatible with the many popular programs and add-ons on the Internet (including Silverlight 4 and earlier). (For Silverlight issues, see "Fix Silverlight Issues" in the related articles at the end of this webpage.) If you see both Internet Explorer and "Internet Explorer (64-bit)" when you click Start and then "All Programs", select the standard 32-bit edition (which has no bit identification) to ensure optimum compatibility with other programs and add-ons.  

To keep from accidentally running the 64-bit edition of IE 9, you can right-click on and delete "Internet Explorer (64-bit)" from the All Programs list and from your Start menu. This removes only the shortcut, not the code itself.  

To determine whether you have opened the 32-bit or 64-bit edition of IE 9, click on the gear icon in the upper-right corner of your browser screen and choose "About Internet Explorer." If you see "64-bit Edition" at the end of the version number, this is a 64-bit IE. There is no bit Edition identification in the 32-bit version number. 

Protected Mode

The Protected Mode of Internet Explorer (IE) utilizes Vista and Windows 7's User Account Control (UAC) to implement the principle of "least privilege" (and therefore is not  supported in Windows XP or earlier). Sometimes this extra security can interfere with legitimate actions over the Internet (such as Adobe Acrobat/Reader opening PDF files in the browser).

Protected Mode can be disabled in IE-9, IE-8  and IE-7 for troubleshooting or for performing specific actions in unprotected mode as follows:

  1. Trusted Site: Open Internet Options > Security tab > select Trusted Sites > click Sites button > un-check "Require server verification (https:)... " > click in the "Add this website to the zone" box and type ctimls.com > click the Add button > click the close button. Protected Mode will remain off for trusted sites. It is recommended that ctimls.com be entered as a trusted site. 
  2. Zone Security: Open the site in Internet Explorer > in the top menu of IE, select Tools (or at the bottom of the screen, double-click on the security zone) > select Internet Options > Security tab > at the top, under "Select a zone to view or change security settings" click on Internet (globe icon) to highlight it > 

    Internet Options Enable Protected Mode screen 

    Below the "Security level for this zone", and directly above the Custom level... and Default level buttons, un-check "Enable Protected Mode" > click OK button > if prompted with "Warning! The current security settings will put your computer at risk", click OK > close all IE screens, then re-open IE for the change to take effect. 

    • To re-enable Protected Mode: open Internet Options > Security tab > select the Internet zone > check "Enable Protected Mode" > click OK button.
  3. IE as Administrator: right-click on the IE icon or shortcut > select "Run as Administrator" > click Allow at the User Account Control screen > "Protected Mode: Off" will display on the status bar at the bottom of IE screens until all IE screens are closed. This is a temporary setting. IE will automatically re-enable Protected Mode when IE is re-opened.
  4. Turn Off UAC: When Vista's or Windows 7's User Account Control is off, this will automatically disable IE Protected Mode. For instructions on configuring User Account Control, see the related article below "Using Windows Vista and Windows 7."

▲ Back to the top of this web page

Reset Internet Explorer 9, 8 or 7

Internet Explorer may become unstable (repeatedly shuts itself down or fails to function properly) after being upgraded, after add-ons (such as extra toolbars, animations, pop-up blocker, weather/stock tracker, etc) have been installed to your browser,  after installing (or uninstalling) a different browser (such as Google Chrome), or after running a "registry cleaner" or similar program. You can reset Internet Explorer back to its original default settings as follows (see warning note below):

  1. Start Internet Explorer (if possible) and select the Tools menu. If Internet Explorer fails, open the Windows Control Panel.
  2. Click on Internet Options
  3. Select the Advanced tab
  4. Click the Reset button
  5. In the "Reset Internet Explorer Settings" dialog box, click Reset to confirm.
  6. You may need to re-start Windows for all changes to take effect. 

Warning Note

Uninstall or Reinstall Internet Explorer

If reset (described above) does not fix an Internet Explorer (IE) display problem, or if Internet Explorer does not work correctly because of damaged files or missing registration information, IE may need to be uninstalled and reinstalled. 

To uninstall Internet Explorer 9 in Windows 7 and Windows Vista

  1. Click the Start button Picture of the Start button, type "Programs and Features" in the search box, and then click "View installed updates" in the left pane. 
  2. Under "Uninstall an update", scroll down to the Microsoft Windows section.

  3. Right-click Windows Internet Explorer 9, click Uninstall, and then, when prompted, click Yes.

  4. Click one of the following:

    • Restart now (to finish the process of uninstalling Internet Explorer 9, and restore the previous version of Internet Explorer); OR 

    • Restart later (to wait until you shut down or restart your computer).

Note: After you uninstall Internet Explorer 9, the previously installed version of Internet Explorer should be available on your computer. It should not be necessary to reinstall IE. 

To uninstall Internet Explorer 8 in Windows 7 (see warning below before uninstalling):

  1. Click Start, and then click Control Panel.
  2. Under Programs click Uninstall a program .
  3. In the tasks pane, click "Turn Windows features on or off".
  4. In the list of windows features, un-check Internet Explorer 8.
  5. Click Yes on the warning message pop-up window. 

Warning: Since Windows 7 comes with IE8 preinstalled (except in the European Union), you will not be able to browse the Internet after uninstalling IE8 until you download and reinstall some Internet browser. If you plan to switch to a different browser (such as Mozilla Firefox, Google Chrome, Opera, or Safari), it is advisable to try to download and install that browser (if possible) before you uninstall IE8. 

To uninstall Internet Explorer 8 in Windows Vista or Windows 7:

  1. Click Start, and then click Control Panel.
  2. In the left pane, click Control Panel Home if you are in Classic View.
  3. Click Uninstall a program under Programs.
  4. In the left panel, click View installed updates.
  5. Wait a few seconds for all updates to appear on the list, then scroll down and select Windows Internet Explorer 8.
  6. Click Uninstall

Note: If Internet Explorer 7 was previously installed on this computer, it should be restored after uninstalling IE8 and restarting Windows. See "How to Reinstall or Repair Internet Explorer" in the related articles below for help resolving IE8 installation issues.

To uninstall Internet Explorer 8 in Windows XP:

  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. Select the Show updates check box if it isn't already. 
  4. Scroll down the list and select Windows Internet Explorer 8, and then click Remove.

To install/reinstall Internet Explorer 8, go to "Install Internet Explorer 8" in the related articles below, click the Download button, and follow Microsoft's prompts. 

To install Internet Explorer 7, go to "Install Internet Explorer 7" in the related articles below, select the version of IE7 appropriate for your version of Windows, and follow Microsoft's prompts. 

▲ Back to the top of this web page

Firefox  Browser Issues

Clear Firefox 3.5+ Browsing History Cache in Windows or Mac

To remove temporary Internet files and cookies in Firefox:

  1. Click Tools in the top toolbar and select "Clear Recent History"
  2. Click on the "Time Range" button and select "Everything"
  3. Click the Details button to choose what history elements to clear
      -  Ensure that Browsing History, Cookies and Cache are checked
  4. Click the Clear Now button.
  5. Close Firefox, and then re-open the browser.

Silverlight or ActiveX Controls in Firefox 

To verify or manage installation of the Silverlight browser plug-in (used to run CTI Navigator Web) in Firefox , click Tools, select Add-ons, and select Plugins in the top menu of the browser. 

A free browser extension called "IE Tab" can be added to Firefox or Chrome in Windows to allow Internet Explorer components to display web pages in a browser tab. This enables you to display web pages that use Microsoft Silverlight (such as CTI Navigator Web) or ActiveX controls within your Firefox or Chrome browser, even if the browser itself does not correctly load Silverlight or ActiveX Controls. The original IE Tab also includes an "Auto URL" filter and a Bookmarks feature that allow you to specify which URLs should always be loaded with IE Tab.

Although it does not open the IE browser per se, IE Tab uses the IE Browser Control core engine. Therefore, to ensure full security when using IE Tab, the latest version of Internet Explorer should be installed in Windows on your computer and it should be kept up-to-date with the latest security patches from Microsoft.  

IE Tab currently runs only in Windows. There is an updated version 2 for both "IE Tab for Firefox" and "IE Tab for Chrome". You can read about and download the original IE Tabs at www.ietab.net.

If the original IE Tab V2 does not work as you would like in Firefox on your computer, you can download a different open source (free) IE Tab extension from http://ietab.mozdev.org/

An alternative to the original "IE Tab for Chrome" is "IE Tab Multi (Enhance)". You can read about IE Tab Multi at http://iblogbox.com/chrome/ietab/alert.php, and download it from the Chrome Webstore.  

Note: Beware that other IE Tab emulators may include adware/spyware/malware. 

To run Silverlight in 64-bit Firefox (ver.4) on Apple OSX, ensure that your version of Silverlight is at least 4.0.60129.0 or later. For help on Silverlight issues, see "Fix SILVERLIGHT Issues" in the related articles below. 

▲ Back to the top of this web page 

Photo Display in Firefox

To set Firefox to automatically display images, click Tools > Options > Content tab > check "Load images automatically". If desired, you also can specify which websites are allowed (or not allowed) to load images by clicking the Exceptions button beside "Load images automatically." The website ctimls.com should be shown as Allow in the Exceptions list. If "Load images automatically" is not checked, place markers may display instead of actual images in MLS reports and web pages. 

Pop-Up Blocker in Firefox

To set the pop-up blocker in Firefox, click Tools > Options > Content tab > Block Pop-Up Windows. If "Block pop-ups windows" is checked, you can either uncheck it to allow pop-up windows; or you can click the Exceptions button beside "Block pop-ups windows" and specify that the website ctimls.com be allowed to open pop-up windows. If all pop-up windows are blocked, several CTI Navigator Web functions (such as Print and preview of MLS Report links in e-mail messages) may not display. For instructions to manage other pop-up blockers, see "Disable or Configure Common Pop-Up Blockers or Remove Add-on Toolbars" in the related articles at the end of this web page. 

How To Display Allowed Pop-ups

To specify how to display allowed pop-ups in Firefox, click the Firefox button (or Tools in the Menu) and select Options. Select Tabs at the top. To open in a New Tab, check "Open new windows in a new tab instead." To open in a New Window, un-check this option (unchecked is the default). 

Manage the Flash Plug-in in Firefox 

The Adobe Flash Player browser plug-in lets you view video and animated content in Firefox. There are two different types of Flash Players: An ActiveX version for Internet Explorer, and a plug-in version for Firefox and other browsers. For Flash to work in Firefox you must install the plug-in version. For instructions on installing Flash in Firefox, see "Installing Flash Plug-in in Firefox" in the related articles below. For other issues using Flash in Firefox, see "Manage the Flash Plug-in in Firefox" in the related articles below. 

▲ Back to the top of this web page

General Diagnostics for Firefox

For detailed steps to identify and correct most known causes of Firefox no longer working properly, see "Standard Diagnostic Steps to Fix Firefox" in the Related Articles below. Abridged and reprinted below are the steps from this article for how to completely uninstall and then reinstall a clean copy of Firefox. 

Uninstall Firefox

To completely remove Firefox:

  1. Download the Firefox installer from Mozilla.com
  2. As a precaution, you may want to make a backup copy of your Firefox profile folder (click these links for specific instructions)
  3. Completely remove your current version of Firefox, as described in "Uninstall Firefox" in the Related Articles below
  4. To start up completely fresh, as though it was never installed before, also remove your user profile data 
  5. Reinstall Firefox by running the installer you downloaded previously (in step 1).

If you removed your user profile data before reinstalling Firefox, it will start up with the Import Wizard, just as if you installed it for the very first time. This will create a new "default" profile. You can then close Firefox and can selectively copy back your important profile data into the new profile, and reinstall your extensions or themes.

Clean Reinstall of Firefox

To reinstall a clean copy of Firefox after first removing the installation directory* (which is the application or program folder): 

  1. Download the Firefox installer from Mozilla.com and save it to your computer. ( Avoid unofficial downloads that bundle Firefox with the Google Toolbar or other software.)
  2. Close Firefox completely
  3. Delete the Firefox installation directory (On Windows, this is typically the C:\Program Files\Mozilla Firefox folder that contains "firefox.exe" and other Firefox program files and folders).
  4. Reinstall Firefox by running the installer you downloaded previously.

*Note: Removing the installation directory does not affect your Firefox profile data such as bookmarks, passwords, cookies, and preference settings, which are stored in a separate location

Another "clean reinstall" method is to first uninstall Firefox (in Windows, do not select the uninstall option to "Remove my Firefox personal data and customizations" unless you want to remove your user profile data). Then reinstall Firefox into a different program folder. (In Windows, use the "Custom" Setup Type and choose a different Destination Folder, e.g., C:\Program Files\Firefox3). 

For instructions to downgrade Firefox to an earlier version, click here

▲ Back to the top of this web page

Chrome Browser Issues

Clear Browsing Data in Chrome

To remove temporary Internet files and cookies in Google Chrome:

  1. Click the Wrench icon on the Chrome top menu  
  2. Click Tools and select "Clear Browsing Data..." (or shortcut is to press Ctrl+Shift+Delete keys on any Chrome screen)
  3. Click the button beside "Obliterate the following items from" and select a time frame.
  4. Ensure that "Clear Browsing History", "Empty the cache", "Delete Cookies and ...plug-in data" are checked
  5. Click the "Clear Browsing Data" button. 
  6. Close all Chrome screens and then re-start Chrome. 

Silverlight in Chrome

To verify or manage installation of the Silverlight browser plug-in (used to run CTI Navigator Web) in Chrome, click the Wrench icon in  Chrome's address bar > select Options (Preferences on a Mac) > click "Under the hood" tab > under Privacy, select "Content Settings" button > select Plug-ins under Features > select "Run automatically (recommended) > click on "Disable individual plug-ins" > browse the list to ensure Silverlight 4.0 or greater is installed > OK > Close

The free browser extension called "IE Tab" can be added to Chrome in Windows to allow Internet Explorer components to display web pages in a tab in Chrome. See a description of and link to IE Tab in the "Silverlight or Active X Controls in Firefox" section above. 

Pop-Up Blocker in Chrome

Google Chrome automatically prevents pop-ups . To see blocked pop-ups in Chrome, click the icon in the address bar. To always see pop-ups for ctimls.com, click the icon and select "Always show pop-ups from ctimls.com". The site will be added to the Exceptions list, which you can manage in the Content Settings dialog (as described below).

To add ctimls.com as an exception so it will not be blocked, click the Wrench icon in  Chrome's address bar > select Options (Preferences on a Mac) > click "Under the hood" tab > select "Content Settings" button under Privacy > select Pop-up under Features > click the Exceptions button > click the Add button and enter "ctimls.com" under Pattern > OK > Close. 

▲ Back to the top of this web page 

Uninstall Google Chrome 

Uninstall Chrome in Windows: You can use Windows' Control Panel to remove Chrome, or follow these steps :

  1. Ensure that you have another browser installed, or a browser install file downloaded in your computer and ready to install.
  2. Go to Start > All Programs > Google Chrome > Uninstall Google Chrome.
  3. If you want to delete your user profile information (such as your browser preferences, bookmarks, and history), select the "Also delete browser data" checkbox.
  4. Select the default browser you'd like to use.
  5. Click OK in the confirmation prompt.

If the normal uninstall methods fail, manually uninstall Chrome in Windows as follows:

  1. Ensure that extensions are displayed for your files. Here's how:
    • Go to the Start menu > Control Panel
    • Double-click Folder Options
    • Click View
    • Un-check "Hide extensions for known file types"
  2. Right-click this link to a file named remove.txt 
  3. Click Save Link as (or Save Target as), select "All files" as the file type, and rename the file to remove.reg when you Save (i.e., change the file extension from txt to reg). 
  4. Exit Google Chrome completely.
  5. Double-click on the remove.reg file that you saved onto your computer (usually on the Windows desktop).
  6. In the confirmation window, click Yes.
  7. Click OK.
  8. Go to the Start menu > Run.
  9. Enter one of the following commands in the text field, depending on your operating system:
    • Windows XP:%USERPROFILE%\Local Settings\Application Data\Google
    • Windows Vista or 7: %LOCALAPPDATA%\Google
  10. Delete the Chrome folder in the directory that opens.

▲ Back to the top of this web page 

Uninstall Chrome in Mac OS X

  1. Go to the folder containing Google Chrome.
  2. Drag Google Chrome to the Trash icon in the Dock. You'll need administrative rights if it's installed in your Applications folder. To remove the Google Chrome icon from your Dock, simply drag it out of the Dock with your mouse.

Safari Browser Issues

Empty Browsing Cache and Cookies in Safari on Mac

To empty the cache of web page data saved by Safari:

  1. Click the word Safari in the browser's top menu and select "Empty cache..."
  2. Click the "Empty" button to confirm.
  3. Close Safari and then re-open the browser. 

To remove cookies and all other data saved by websites in Safari:

  1. Click the word Safari in the browser's top menu and select Preferences...
  2. Click the "Remove All Website Data" button; or  
      -  To select and remove data for a specific website (such as ctimls.com),
         click the Details button instead of the "Remove All Website Data" button. 
  3. Close Safari and then re-open the browser. 

Pop-Up Blocker in Safari

To disable the Pop-Up Blocker in Safari, select Edit in the toolbar and un-check "Block Pop-Up Windows." A shortcut is to hold down the Control+Shift key and press the "K" key on your keyboard.

▲ Back to the top of this web page 

Silverlight in Safari

To verify or manage installation of the Silverlight browser plug-in (used to run CTI Navigator Web) in Safari, click Help and select "Installed Plugins" in the top menu of the browser. 

To troubleshoot problems using Silverlight in Safari, see "Fix Broken Installation of Silverlight in Mac Using Safari" in the related articles at the end of this web page. 

To uninstall Silverlight on an Apple Mac:

▲ Back to the top of this web page 

Browser Errors in Windows

Active X error

To fix an "Active X" error that appears when you click on a Web-link, disable or configure your Internet pop-up blocker to allow pop-ups on the desired website. This is described in the related article, "Fix Active X error".

Class Does Not Support Automation or Expected Interface error

To fix an "Class does not support Automation or Expected Interface" error that appears when you click on a Web-link in Windows, close all browser screens and re-register the actXprxy.dll and ScrRun.dll files in your Windows\System32.

  1. Click on Start
  2. In Windows 7 or Vista:
    • type cmd  in the Search box
    • Right-click on cmd.exe and choose Run as administrator
    In Windows XP
    • select Run > type cmd  in the Open box > click OK
  3. Type Regsvr32 actxprxy.dll  and press Enter
  4. Type Regsvr32 scrRun.dll  and press Enter
  5. Click Ok to close the "DllRegisterServer in actxprxy.dll succeeded" screen.

If re-registering actxprxy.dll and ScrRun.dll does not resolve the error, follow the instructions above to re-register all Internet Explorer original files and to reset your version of Internet Explorer. This should also reset Internet connectivity components in Windows, regardless of which browser is set as the default. (See the warning note before re-setting Internet Explorer.)

Subscript Out of Range error

To fix a "Subscript Out of Range" error that appears when you click on a Web-link, follow the instructions on the Fix Subscript Out of Range error web page.

▲ Back to the top of this web page

Note. Please be advised that CTI does not accept any responsibility for software you download, or for information provided about settings or software not produced by CTI (see "CTI Disclaimers" in the Related Articles below).


Related articles and Internet links:

To go to CTI's menu of Instructions to Fix Errors, click here or use the back arrow at the top of your Internet browser. 

To return to a list of Login Errors, click here

 

 

 

rev.  09.03.2012