Internet Browser Display Issues

For CTI Navigator Web to be able to provide all of the functions of an MLS system inside your Internet browser, the browser itself must be fully functional, and the Microsoft Silverlight plug-in must be properly installed and fully enabled in the browser.  Also, other programs and settings must not interfere with Navigator's operations. Things that could interfere include damaged website files saved in your browser's history, corrupted Silverlight files, corrupted or incompatible browser files, pop-up blockers, advertiser supported browser toolbars and add-ons, or incompatible Internet browsing security settings. 

See the table below for some general diagnostic information and links to corrective guidelines. If you don't see your problem listed or need additional details, scroll to the Topic Index below the table, select your browser, and click on the appropriate topic for your browser to go directly to detail information relevant to that topic.

Problem using CTI Navigator Web Corrective Actions
Sign-in screen fails to open, is blank, or repeatedly prompts to download Silverlight;  - or -

Frame menu items are missing or grayed out.

  1. Clear stored browsing history data (in Internet ExplorerFirefoxChromeSafari on Mac)^
  2. In Internet Explorer browser, turn-off ActiveX Filtering
  3. In Windows 8.1, open Internet Explorer in Desktop Mode (with address bar at top of screen).
  4. Un-install then re-install Silverlight^;
  5. Enable Silverlight in Internet Explorer; or "Always Activate" in Firefox (Windows or Mac); 
  6. Reset browser to its original defaults (Internet Explorer, Firefox, Chrome, Safari on Mac);
  7. Repair the browser

    See the Topic Index below for help with your specific browser.

Sign-in and/or other screens are very slow to open.
  1. Add the Navigator website for your MLS to your browser's Favorites, and
  2. Enable website caching.
Print dialog boxes, web links, frame menu, or virtual tours do not display. Disable or configure Pop-Up Blocker(s)^ to allow popup screens at ctimls.com.
Linked PDF Files^ fail to open in the browser.
  1. Restore browser default settings^;
  2. Clear stored browsing data^
  3. Set security to trust and allow access to ctimls.com^;
  4. Repair (Adobe) PDF reader^.
Highlighted text (or icon) disappears when mouse controlled cursor passes over.
  1. Close all browser screens (or re-start your computer), and then re-open only Navigator Web;
  2. Disable or remove un-necessary browser Add-ons,Toolbars or malware installed settings;
  3. Set Internet Options to use GPU rendering (not software rendering) for Accelerated Graphics;
  4. Adjust Internet Explorer's Zoom Setting;
  5. Set Internet Explorer to Compatibility View;
  6. Reset browser to its original defaults (Internet Explorer, Firefox, Chrome, Safari on Mac).
Silverlight crashes frequently or fails to properly display all Navigator Web pages in Chrome or Firefox. Install the "IETab" browser extension for Chrome or IE Tab for Firefox. Otherwise, see the appropriate sections in "Fix Silverlight issues."
Specific error message. Follow specific instructions for specific error (also on CTI's Fix Errors web page).
System Exception error in any Windows browser, or in Safari on a Mac.
  1. Clear your browser's temporary Internet files (Internet Explorer, Firefox, Chrome, or Safari), close all browser screens, and then re-open only Navigator Web.
  2. On a Mac, click here for summary (or click here for details) to un-restrict Silverlight specifically for your MLS website.
  3. On Windows or Mac, un-install Silverlight and then install the latest version of Silverlight.
Tutorial Videos or Virtual Tour videos do not display.
  1. Enable the Adobe Flash Player in your browser (select under your browser in the Index below).
  2. In IE 9 and later, also Disable ActiveX Filtering for the affected website.
CTI Navigator Desktop Internet login error. Select Login and Related Errors^ on CTI's Fix Errors web page .


^Note: Use the Index below to go directly to instructions for your browser on this web page. Some links in this table go to articles outside this web page for additional detail. If you go outside this web page, use the back arrow at the top of your Internet browser to return to this web page. 

Topic Index:

Internet Explorer 

Firefox

Chrome

Safari

Non Browser-Specific Errors

Related Articles and Internet Links, such as: 


Internet Explorer Issues

Delete Browsing History

If returning to a previously visited website (such as CTI Navigator Web) fails or new entries at a website do not function properly, the problem could be a corrupted file in the browser's history. These files are saved (cached) as temporary Internet files for convenience (to improve browsing speed - see "Enable Website Caching" below - and to save having to type the same information over and over). They can all be safely deleted. ( See note 3 below if CTI Navigator Web fails to display the sign-in screen.)

To automatically delete Internet Explorer's browsing history: (for other browsers, see the index at the top of this web page)

  1. Open Internet Options (in Windows Control Panel; or in IE under Tools; or click the Safety icon)
  2. Under the General tab, click the Delete button in the Browsing History section
  3. Normally, check "Preserve Favorites Website Data". However, if you want to be thorough and include deleting favorite website information (some of which might be corrupted), un-check "Preserve Favorites Website Data". 
  4. Check all other boxes (or, at a minimum, check Temporary Internet Files, and Cookies)
  5. Click the Delete button. This could take awhile if you have a lot of files and history stored
  6. After deletion completes, and Internet options re-opens on the General tab:

Note 1

If using the delete button in the Internet Options Browsing history (as described above) does not resolve the problem (the automatic approach may not remove some corrupted files), you can manually delete Temporary Internet Files as follows: 

  1. Open Internet Options (or see the note 2 below) 
  2. Under the General tab, click the Settings button in the Browsing History section 
  3. Click the View Files button 
  4. Highlight the Temporary Internet Files folder
  5. Click Edit > Select All > Delete.

Note 2. You also can browse in Windows Explorer to the Temporary Internet Files folder and delete its files. In Windows 7 and 8, this folder is usually under C:\Users\{YourName}\AppData\Local\Microsoft\Windows\INetCache.  In Windows Vista, this folder is usually under C:\Users\{YourName}\AppData\Local\Microsoft\Windows\Temporart Internet Files. In Windows XP it usually is under C:\Documents and Settings\{Your Name}\ Local Settings\

Reset IE. If your Internet Explorer has become unstable (repeatedly shuts itself down) or fails to function properly even after deleting temporary files (described above), you can reset the browser to its original defaults.  A Reset will delete all settings that have changed since Internet Explorer was first installed, including browsing history. See the Reset Internet Explorer to defaults section below for instructions to reset IE. 

Note 3: If the website fails to display the sign-in screen for CTI Navigator Web, ensure that your browser's history has been cleared (select for your browser in the index at the top of this web page) and also ensure that Silverlight is properly installed and enabled to run in your browser (select for your browser in the index at the top of this web page). For detail instructions on installing and fixing Silverlight, click "Fix Silverlight Issues" (in the index or in the Related Articles).   

▲ Back to the TOPIC Index at the top of this web page 

Enable Website Caching

If the sign-in page or other pages for CTI Navigator Web are very slow to load, your browser's caching settings may need to be adjusted. Caching can drastically improve browsing speed and efficiency because it allows the browser to store key web page information locally in your computer. Cached information can be very quickly re-used (significantly faster) rather than repeatedly re-requesting and re-downloading information over the Internet every time the webpage is visited.

To set Internet Explorer to use caching to improve page loading performance for CTI Navigator Web (and your other Favorite websites):

  1. Open Internet Explorer
  2. Browse to the sign-in web page of CTI Navigator Web for your MLS
  3. Add or verify that the address of CTI Navigator Web for your MLS is in the browser Favorites
  4. Click on Tools or Tools icon () in the browser and select Internet Options 
  5. Under "Browsing History" on the General tab of Internet Options, click the "Delete..." button
  6. Check "Preserve Favorites website data" (and check any items you want to clear for non-Favorite websites), and click the Delete button.
  7. Under "Browsing History" on the General tab of Internet Options, click the "Settings..." button, and
  8. Click the OK button on the General tab of  Internet Options screen.

Other actions that may improve web page loading speed are: keep fewer tabs open in the browser; disable un-needed browser add-ons (select "Manage Add-ons" under Tools); cleanup temporary browser history files; configure or disable website safety filtering (an option in some Internet Security programs); under the Advanced tab of Internet Options, select "Restore Advanced Settings" to their defaults.

Unblock Web-Links or Virtual Tour Links

When web-links or Virtual Tour web pages from CTI Navigator do not display in your Internet browser and do not display an error message, it usually is because a pop-up-blocker is preventing the display. To unblock the display, configure or disable your pop-up-blocker for the web address of the web link or virtual tour. For instructions on managing pop-up blockers, see "Disable or Configure Common Pop-Up Blockers or Remove Add-on Toolbars" in the related articles at the end of this web page. See the section below on this web page for how to allow desired Pop-Ups

If an error message displays when you click on a Web-Link, see the "Display Web Links" section below; or select that error message in the Errors section of this webpage, or select that error message on CTI's Instructions to Fix Errors webpage to see instructions specific to that error. 

Display Allowed Pop-ups

Your browser can be set to display pop-ups that appear as a result of you clicking on a link or button, or automatic pop-ups from trusted sites in either a new Window or in a new Tab. The default setting normally is to open in a new Window.  

To specify how to display allowed pop-ups in Internet Explorer, click Internet Options. On the General tab, click the Settings button in the Tab section ("Change how web pages are displayed in tabs"). Then check your preference under "When a pop-up is encountered". The default is "Always open pop-ups in a new window." There is a button you can click to "Restore defaults." 

Display Web Links

Sometimes Internet Explorer fails to open a new Tab or new Window in which to display a linked website. An error may or may not display. This can be caused by missing or corrupted registration of some Internet Explorer system libraries (dll files) - especially in Windows 7.  

To re-register the original Internet Explorer (IE) files from Microsoft, close all browser pages and click on the link below appropriate for your version of Windows and your version of Internet Explorer. 

In Windows Vista, 7, or 8,  first save the file to your computer. Then right-click on any ".bat" file or any "cmd" file after unzipping, and choose "Run as Administrator." 

In Windows XP, you can open/run or save the file. Then unzip the file and double-click on any cmd file or any .bat file.

Close the black screen after the file runs. 

An alternative approach to re-registering files needed by Internet Explorer 7 through 9  is to run the "Fix IE Utility" freeware (see Repair Internet Explorer 7, 8, and 9  with "Fix IE Utility" in the related articles at the end of this web page). Always exercise extra caution using freeware (see disclaimer below).  

If this does not resolve the problem, follow the appropriate instructions below to reset your version of Internet Explorer . This should also reset Internet connectivity components in Windows, regardless of which browser is set as the default. (See the warning note before re-setting Internet Explorer.)

▲ Back to the TOPIC Index at the top of this web page 

Change Website Compatibility View 

When Internet Explorer 11, 10 or 9 does not properly display web pages or HTML links, you can set it to allow content compatible with previous versions by using the "Compatibility View Settings" as follows:

  1. Open Internet Explorer
  2. Click on Tools at the top (or    in IE-11, or  in IE-10 or 9)
  3. Select "Compatibility View Settings
  4.  
  5. In the "Add this website" box, enter  *ctimls.com (or the specific address of CTI Navigator Web for your MLS) and click the Add button. 
      (click on image to enlarge)
  6. Click the Close button.

▲ Back to the TOPIC Index at the top of this web page

Disable Active X Filtering

If your computer is using Internet Explorer 9, 10 or 11 and CTI Navigator Web's sign-in screen fails to open, is blank, or repeatedly prompts to download Silverlight, or Navigator Web opens but the frame menu items are not visible, your browser may be set to "filter" (block) ActiveX controls, or a browser add-on/toolbar may be interfering with  a display function (see "Disable Un-necessary Add-ons and Toolbars" below).  Active filtering is indicated by the icon in the address bar. 

To set Internet Explorer (9 and later) not to filter ActiveX controls such as used by Silverlight on the CTI Navigator website for your MLS: select Tools in Internet Explorer's menu bar and un-check "ActiveX Filtering"; or click the Tools icon , select Safety, and un-check "ActiveX Filtering". Disabling ActiveX Filtering on the CTI Navigator website is site specific, so you still can enable ActiveX Filtering for other websites if you prefer. (For more information, see Microsoft's ActiveX Filtering web page in the related articles at the end of this webpage.) 

Disable Un-necessary Add-ons and Toolbars

Some browser add-ons and free toolbars (such as Ask.com, Babylon, Crawler, FunWebProducts, InfoAtoms, MyWebSearch, MySearch, MySearchResults, My Way Speedbar,Search Assistant, Search Here) or desktop gadget adware (such as WeatherBug or WhenU) may interfere with Navigator display functions. 

Embedded Note: If you remove/uninstall a toolbar/browser add-on that was embedded in a free product, you will no longer have access to the free product or feature. To continue to be able to access the underlying product sometimes, temporarily disable the add-on

For specific instructions to disable, configure or remove some of the most common toolbars (and pop-up lockers), see "Disable or Configure Common Pop-Up Blockers or Remove Add-on Toolbars" in the related articles at the end of this web page.

Enable Adobe Flash Add-on to View Videos

The free Adobe Flash Player browser plug-in lets you view video and animated content in an Internet browser. There are two different types of Flash Players: An ActiveX version for Internet Explorer, and a plug-in version for Firefox and other browsers.

To view tutorial videos the Adobe Flash Player add-on must be operating properly in your browser. If your computer does not already have Adobe’s Flash Player, it can be downloaded from  http://get.adobe.com/flashplayer/ . For help installing Flash Player, see "Adobe Flash Player Help: Download, Install, Enable and Verify" (in the related articles at the end of this webpage.) 

To enable the Adobe Flash Player (labeled "Shockwave Flash Object" because it is an ActiveX control in Internet Explorer):

  1. Select Tools menu or Tools icon > Manage Add-ons. (Or choose Tools > Internet Options >Programs tab > Manage Add-ons.)
  2. Under "Add-on Types" on the left,  select "Toolbars and Extensions"
  3. Under "Show:" on the lower left, click the down button beside "Currently loaded add-ons" and select "All add-ons"
  4. On the right, scroll down the "Name" column and select "Shockwave Flash Object"
  5. Click the "Enable" button in the lower-right. (Do not click the button if it displays Disable.)
  6. Close the Manager Add-on window and refresh or re-start the browser

In Internet Explorer 9 and later, you also may need to disable ActiveX Filtering (see description above) to allow the Flash plug-in to function.

Note: Flash Player is embedded as a "Microsoft Windows Third Party Application Component" in Internet Explorer 11 for Windows 8 and 8.1.

Adjust Zoom in Internet Explorer

If text or icons disappear when highlighted (such as by passing the cursor over them), the display settings for the browser may need to be adjusted. This may happen after upgrading your Internet Explorer to version 11.  Usually, the easiest way to fix this display issue in Internet Explorer is to change its Zoom settings (either smaller or larger than your current setting, depending on the size and resolution of your monitor). The normal default Zoom setting when the monitor is set to its recommended native resolution is 100%. (To check resolution, see “Display” in the Windows Control Panel.) 

Note that if your Internet browser is set to a zoom factor other than 100% (the normal default), clicking your mouse may not set the curser to the expected position on a web page (such as inside a text entry box in Navigator Web). If this happens but you want to keep your current zoom setting, you can use the four up/down-left/right arrow keys (Positioning Arrow Key s on keyboard) on your keyboard to position the cursor to the desired position.

 
To change the Zoom in IE, either click on View in the browser Menu Bar (or the Tools icon ) and select Zoom; or hold the Ctrl key down and scroll the mouse wheel (up to increase size, or down to decrease size); or hold the Ctrl key down and press the plus (+) key to increase size, or minus (–) key to decrease size. You should immediately see on-screen the effect of any change in zoom. Normally you only need to adjust by one preset level (up or down by 25%) to prevent text or icons from disappearing when you scroll through a web page display.

Blank lines or images on a web page also can happen when there are too many browser screens all open at the same time (which can interfere with screen refreshing). You can check if there is a resource constraint in your computer by either closing all browser screens and all other programs, or by re-starting Windows, and then open only CTI Navigator Web in a fresh (new session) browser screen.

IE 9  64-bit Incompatibility 

As of winter 2012, the 64-bit Edition of Internet Explorer 9 is not compatible with the many popular programs and add-ons on the Internet (including Silverlight 4 and earlier). (For Silverlight issues, see "Fix Silverlight Issues" in the related articles at the end of this webpage.) If you see both Internet Explorer and "Internet Explorer (64-bit)" when you click Start and then "All Programs", select the standard 32-bit edition (which has no bit identification) to ensure optimum compatibility with other programs and add-ons.  

To keep from accidentally running the 64-bit edition of IE 9, you can right-click on and delete "Internet Explorer (64-bit)" from the All Programs list and from your Start menu. This removes only the shortcut, not the code itself.  

To determine whether you have opened the 32-bit or 64-bit edition of IE 9, click on the Tools icon in the upper-right corner of your browser screen and choose "About Internet Explorer." If you see "64-bit Edition" at the end of the version number, this is a 64-bit IE. There is no bit Edition identification in the 32-bit version number. 

▲ Back to the TOPIC Index at the top of this web page

Temporarily Disable Protected Mode

Starting with Windows Vista (and later), Internet Explorer (IE) can be set to a Protected Mode that utilizes Windows' User Account Control (UAC) to implement the principle of "least privilege". (User Account Control is not available in Windows XP or earlier). Sometimes this extra security can interfere with legitimate actions over the Internet (such as Adobe Acrobat/Reader opening PDF files in the browser).

Protected Mode can be disabled in IE-7 through IE-11 for troubleshooting or for performing specific actions in unprotected mode as follows:

  1. Trusted Site: Open Internet Options > Security tab > select Trusted Sites > click Sites button > un-check "Require server verification (https:)... " > click in the "Add this website to the zone" box and type ctimls.com > click the Add button > click the close button. Protected Mode will remain off for trusted sites. It is recommended that ctimls.com be entered as a trusted site. 
  2. Zone Security: Open the site in Internet Explorer > in the top menu of IE, select Tools (or at the bottom of the screen, double-click on the security zone) > select Internet Options > Security tab > at the top, under "Select a zone to view or change security settings" click on Internet (globe icon) to highlight it > 

    Internet Options Enable Protected Mode screen (click on image to enlarge)

    Below the "Security level for this zone", and directly above the Custom level... and Default level buttons, un-check "Enable Protected Mode" > click OK button > if prompted with "Warning! The current security settings will put your computer at risk", click OK > close all IE screens, then re-open IE for the change to take effect. 

    • To re-enable Protected Mode: open Internet Options > Security tab > select the Internet zone > check "Enable Protected Mode" > click OK button.
  3. IE as Administrator: right-click on the IE icon or shortcut > select "Run as Administrator" > click Allow at the User Account Control screen > "Protected Mode: Off" will display on the status bar at the bottom of IE screens until all IE screens are closed. This is a temporary setting. IE will automatically re-enable Protected Mode when IE is re-opened.
  4. Turn Off UAC: When Windows' User Account Control is off, this will automatically disable IE Protected Mode. For instructions on configuring User Account Control, see the "Use Windows Vista and Windows 7" related article at the end of this web page.

▲ Back to the TOPIC Index at the top of this web page

Reset Internet Explorer (11, 10, 9, 8 or 7)

Internet Explorer may become unstable (repeatedly shuts itself down or fails to function properly) after being upgraded, after add-ons (such as extra toolbars, animations, pop-up blocker, weather/stock tracker, etc) have been installed to your browser, after installing (or uninstalling) a different browser (such as Google Chrome), or after running a "registry cleaner" or similar program. You can reset Internet Explorer back to its original default settings as follows (see warning note below):

  1. Start Internet Explorer (if possible) and select the Tools menu. If Internet Explorer fails, open the Windows Control Panel.
  2. Click on Internet Options
  3. Select the Advanced tab
  4. Click the Reset button
  5. In the "Reset Internet Explorer Settings" dialog box, click Reset to confirm.
  6. You may need to re-start Windows for all changes to take effect. 

Warning Note

For Microsoft's instructions to reset Internet Explorer, see "Reset Internet Explorer settings" (in the related articles at the end of this web page). 

Add-on Fix: See "Disable or Configure Common Pop-Up Blockers or Remove Add-on Toolbars" in the related articles at the end of this web page.  For an automated fix, see  "Microsoft Automated Fix Internet Explorer add-on problems when IE hangs or freezes" (in the related articles at the end of this web page). 

Uninstall or Reinstall Internet Explorer

If reset (described above) does not fix an Internet Explorer (IE) display problem, or if Internet Explorer does not work correctly because of damaged files or missing registration information, IE may need to be repaired by uninstalling and reinstalling

To uninstall Internet Explorer 11, 10 or 9 in Windows 8, 7 or Vista:

  1. Open "View installed updates" in the Windows Control Panel: 
    • In Windows 8 or 8.1: Open the Quick Link Menu (Windows logo key Windows 8 logo key + X, or in Windows 8.1 right-click on Start icon) or open the Settings Charm, and select Control Panel. Then  
      • in Category View: click "Uninstall a Program" under Programs, and select "View installed updates"
      • in Icon View: click on "Programs and Features" and select "View installed updates".
    • In Windows 7 or Vista: Click the Start button Picture of the Start button, type "Programs and Features" in the search box, and then click "View installed updates" in the left pane. 
  2. Under "Uninstall an update", scroll down to the "Microsoft Windows" section. 
  3. Right-click Windows Internet Explorer 10 or 9, click Uninstall, and then, when prompted, click Yes.
  4. Click one of the following:

    • Restart now (to finish the process of uninstalling the current version of Internet Explorer, and restore the previous version of Internet Explorer); OR 

    • Restart later (to wait until you shut down or restart your computer).

Note: After you uninstall Internet Explorer 11, 10 or 9, the previously installed version of Internet Explorer (or the version that came preinstalled in your Windows) should be available on your computer. If IE9 or IE10 was originally included in your Windows, uninstalling IE still leaves it available to be re-installed from Windows files. It should not be necessary to download IE to re-activate the originally installed version. 

For Microsoft's instructions to repair Internet Explorer, see "Repair or Reinstall Internet Explorer (11 and earlier) in your version of Windows" in the related articles .

▲ Back to the TOPIC Index at the top of this web page

To uninstall Internet Explorer 8 in Windows 7 (see warning below before uninstalling):

  1. Click Start, and then click Control Panel.
  2. Under Programs click Uninstall a program .
  3. In the tasks pane, click "Turn Windows features on or off".
  4. In the list of windows features, un-check Internet Explorer 8.
  5. Click Yes on the warning message pop-up window. 

Windows 7 warning: Since Windows 7 comes with IE8 preinstalled (except in the European Union), you will not be able to browse the Internet after uninstalling IE8 until you download and reinstall another Internet browser, or you successfully re-activate IE8. If you plan to switch to a different browser (such as Mozilla Firefox, Google Chrome, Opera, or Safari), it is advisable to download and install that browser (if possible) before you uninstall IE8. 

To uninstall Internet Explorer 8 in Windows Vista or Windows 7:

  1. Click Start, and then click Control Panel.
  2. In the left pane, click Control Panel Home if you are in Classic View.
  3. Click Uninstall a program under Programs.
  4. In the left panel, click View installed updates.
  5. Wait a few seconds for all updates to appear on the list, then scroll down and select Windows Internet Explorer 8.
  6. Click Uninstall

Note: If Internet Explorer 7 was previously installed on this computer, it should be restored after uninstalling IE8 and restarting Windows. See "How to Reinstall or Repair Internet Explorer" in the related articles below for help resolving IE8 installation issues.

To uninstall Internet Explorer 8 in Windows XP:

  1. Click Start, and then click Control Panel.
  2. Click Add or Remove Programs.
  3. Select the Show updates check box if it isn't already. 
  4. Scroll down the list and select Windows Internet Explorer 8, and then click Remove.

Windows XP warning: To ensure that you can access the Internet, it is advisable to download and install another browser (if possible) before you uninstall IE8 in Windows XP. 

To install/reinstall Internet Explorer 8, go to "Install Internet Explorer 8" in the related articles below, click the Download button, and follow Microsoft's prompts. 

To install Internet Explorer 7, go to "Install Internet Explorer 7" in the related articles below, select the version of IE7 appropriate for your version of Windows, and follow Microsoft's prompts. 

▲ Back to the TOPIC Index at the top of this web page

Firefox Browser Issues

Clear Firefox Browsing History Cache in Windows or Mac

To remove temporary Internet files and cookies in Firefox:

  1. Click the Menu button in the top toolbar, choose History, and then select "Clear Recent History
    • Alternatively, you can click Tools in the top toolbar, select Options, Privacy tab, then "Clear Recent History"
    • In older versions, click Tools in the top toolbar, then select "Clear Recent History"
  2. Click on the "Time Range" button and select "Everything"
    (click on image to enlarge if desired)
  3. Click the Details button to choose what history elements to clear
      -  Ensure that Browsing & Download History, Cookies and Cache are checked
  4. Click the Clear Now button.
  5. Close Firefox, and then re-open the browser.

For details and screenshots, including how to set Firefox to automatically clear history, see "Remove Recent Browsing, Search and Download History in Firefox (by Mozilla)" in the Related Articles at the end of this web page.

Silverlight or ActiveX Controls in Firefox 

To verify or manage installation of the Silverlight browser plug-in (used to run CTI Navigator Web) in Firefox , click Tools, select Add-ons, and select Plugins in the top menu of the browser. Beside "Silverlight Plug-in" verify or click the Enable button in Windows or "Always Activate" on a Mac.

If desired, a free browser extension called "IE Tab" can be added to Firefox or Chrome in Windows to allow Internet Explorer components to properly display web pages in a browser tab. This extension enables your browser to display web pages that use Microsoft Silverlight (such as CTI Navigator Web) or ActiveX controls (such as required by Formulator or TrueForms) in a tab, even if the browser itself does not correctly load Silverlight or ActiveX Controls. The IE Tab also includes a URL Site Filter that allows you to specify which URLs should always be loaded with IE Tab 2 in the browser.

Although it does not open the IE browser per se, IE Tab uses the IE Browser Control core engine. Therefore, to ensure full security when using IE Tab, the latest version of Internet Explorer should be installed in Windows on your computer and it should be kept up-to-date with the latest security patches from Microsoft.  

There is a version of IE Tab for Firefox  and a separate version for Chrome. You can read about and download either version at www.ietab.net. For instructions on adding IE Tab to Firefox or Chrome, click here.

If the "IE Tab 2" does not work as you would like in Firefox on your computer, you can download a different open source (free) IE Tab extension from http://ietab.mozdev.org

An alternative to the original "IE Tab for Chrome" is "IE Tab Multi (Enhance)". You can read about IE Tab Multi at http://iblogbox.com/chrome/ietab/alert.php, and download it from the Chrome Webstore.  

Note: Be careful to click on the correct download button on the IETab.net home page. Also beware that other IE Tab emulators may include adware, spyware, or malware. 

To run Silverlight in 64-bit Firefox (ver.4) on Apple OSX, ensure that your version of Silverlight is at least 4.0.60129.0 or later. For help on Silverlight issues, see "Fix SILVERLIGHT Issues" in the Related Articles at the end of this web page.

▲ Back to the TOPIC Index at the top of this web page  

Photo Display in Firefox

To set Firefox to automatically display images, click Tools > Options > Content tab > check "Load images automatically". If desired, you also can specify which websites are allowed (or not allowed) to load images by clicking the Exceptions button beside "Load images automatically." The website ctimls.com should be shown as Allow in the Exceptions list. If "Load images automatically" is not checked, place markers may display instead of actual images in MLS reports and web pages. 

Pop-Up Blocker in Firefox

To set the pop-up blocker in Firefox, click Tools (or the menu button) > Options > Content tab > Block Pop-Up Windows. If "Block pop-ups windows" is checked, you can either uncheck it to allow pop-up windows; or you can click the Exceptions button beside "Block pop-ups windows" and specify that the website ctimls.com be allowed to open pop-up windows. If all pop-up windows are blocked, several CTI Navigator Web functions (such as Print and preview of MLS Report links in e-mail messages) may not display. For instructions to manage other pop-up blockers, see "Disable or Configure Common Pop-Up Blockers or Remove Add-on Toolbars" in the related articles at the end of this web page. 

How To Display Allowed Pop-ups

To specify how to display allowed pop-ups in Firefox, click the Firefox button (or Tools in the Menu) and select Options. Select Tabs at the top. To open in a New Tab, check "Open new windows in a new tab instead." To open in a New Window, un-check this option (unchecked is the default). 

Manage the Flash Plug-in in Firefox 

The Adobe Flash Player browser plug-in lets you view video and animated content in Firefox. There are two different types of Flash Players: An ActiveX version for Internet Explorer, and a plug-in version for Firefox and other browsers. For Flash to work in Firefox you must install the plug-in version. For instructions on installing Flash in Firefox, see "Installing Flash Plug-in in Firefox" in the related articles below. For other issues using Flash in Firefox, see "Manage the Flash Plug-in in Firefox" in the related articles below. 

▲ Back to the TOPIC Index at the top of this web page

Reset Firefox to its default state (reprinted from Firefox help)

  1. Click the Firefox menu button () and then click the Help icon ().
     
    (Click on image to enlarge)

    Note: In older versions of Firefox, at the top of the Firefox window, click the Firefox button, go over to the Help sub-menu and select Troubleshooting Information.

       (Click on image to enlarge)
    If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting information page.
  2. Click the Reset Firefox button in the upper-right corner of the Troubleshooting Information page.
    (Click on image to enlarge)
  3. To continue, click Reset Firefox in the confirmation window that opens.
  4. Firefox will close and be reset. When it's done, a window will list the information that was imported. Click Finish and Firefox will open.

What does the Firefox Reset feature do?

All of your Firefox settings and personal information are stored in a profile folder. The reset feature works by creating a new profile folder for you while saving your important data.

Firefox will save these things:

These items and settings will be removed:

Note: Your old Firefox profile will be placed on your desktop in a folder named "Old Firefox Data." If the reset didn't fix your problem you can restore some of the information not saved by copying files to the new profile that was created. If you don't need this folder any longer, you should delete it as it contains sensitive information.

General Diagnostics for Firefox

For detailed steps to identify and correct most known causes of Firefox no longer working properly, see "Standard Diagnostic Steps to Fix Firefox" and "Firefox crashes - Troubleshoot, prevent and get help fixing crashes" in the Related Articles below. Abridged and reprinted below are the steps for how to completely uninstall and then reinstall a clean copy of Firefox. 

Uninstall Firefox

To completely remove Firefox:

  1. Download the Firefox installer from Mozilla.com
  2. As a precaution, you may want to make a backup copy of your Firefox profile folder (click these links for specific instructions)
  3. Completely remove your current version of Firefox, as described in "Uninstall Firefox" in the Related Articles below
  4. To start up completely fresh, as though it was never installed before, also remove your user profile data 
  5. Reinstall Firefox by running the installer you downloaded previously (in step 1).

If you removed your user profile data before reinstalling Firefox, it will start up with the Import Wizard, just as if you installed it for the very first time. This will create a new "default" profile. You can then close Firefox and can selectively copy back your important profile data into the new profile, and reinstall your extensions or themes.

Clean Reinstall of Firefox

To reinstall a clean copy of Firefox after first removing the installation directory* (which is the application or program folder): 

  1. Download the Firefox installer from Mozilla.com and save it to your computer. ( Avoid unofficial downloads that bundle Firefox with the Google Toolbar or other software.)
  2. Close Firefox completely
  3. Delete the Firefox installation directory (On Windows, this is typically the C:\Program Files\Mozilla Firefox folder that contains "firefox.exe" and other Firefox program files and folders).
  4. Reinstall Firefox by running the installer you downloaded previously.

*FF Profile Data Note: Removing the installation directory does not affect your Firefox profile data such as bookmarks, passwords, cookies, and preference settings, which are stored in a separate location

Another "clean reinstall" method is to first uninstall Firefox (in Windows, do not select the uninstall option to "Remove my Firefox personal data and customizations" unless you want to remove your user profile data). Then reinstall Firefox into a different program folder. (In Windows, use the "Custom" Setup Type and choose a different Destination Folder, e.g., C:\Program Files\Firefox3). 

For instructions to downgrade Firefox to an earlier version, click here

▲ Back to the TOPIC Index at the top of this web page

Chrome Browser Issues

Clear Browsing Data in Chrome

To remove temporary Internet files and cookies in Google Chrome:

  1. Click the Chrome Menu icon on the browser toolbar  
  2. Click Tools  
  3. Select "Clear Browsing Data..." (or a shortcut is to simultaneously press the Ctrl+Shift+Delete keys on any Chrome screen)
  4. Click the button beside "Obliterate the following items from" and select "the beginning of time" to delete everything (or select a specific time frame)
  5. Check "Clear Browsing History", "Empty the cache", "Delete Cookies and ...plug-in data", and any other type of information that you want to remove
  6. Click the "Clear Browsing Data" button. 
  7. Close all Chrome screens and then re-start Chrome. 

Silverlight in Chrome

While Silverlight version 5 can run in Chrome on a Mac, it is not recommended because it does not support keyboard input (typing text), such as entering your user name (agent code) and password on the sign-in page of CTI Navigator Web. If desired, you can either create, copy (+C) and paste (+V) textual input information from another source (such as Apple's Notes or Spotlight) into Silverlight 5 applications on a Mac; or install only version 4 of Silverlight (which does support keyboard input).

To verify the version or manage installation of the Silverlight browser plug-in (needed to run CTI Navigator Web) in Chrome, type "chrome://plugins" in the browser URL/Search omnibox, scroll to Silverlight,  and select the Always allowed checkbox.  Alternatively, click the Chrome Menu icon   on the browser toolbar > select Settings > click Show advanced settings (at the bottom) > in the "Privacy" section, click the Content Settings button > in the Plug-ins section, select "Run automatically (recommended)" > click Manage exceptions > enter Silverlight > select Allow as the Behavior > OK > Close. 

In older versions of Chrome, click the Wrench icon in  Chrome's header > select Options (Preferences on a Mac) > click "Under the hood" tab > under Privacy, select "Content Settings" button > select Plug-ins under Features > select "Run automatically (recommended) > click on "Disable individual plug-ins" > browse the list to ensure Silverlight 4.0 (or greater if appropriate) is installed > OK > Close.

The free browser extension called "IE Tab" can be added to Chrome in Windows to allow Internet Explorer components to display web pages more reliably in a tab in Chrome. This can be useful if Silverlight crashes frequently on your computer. See a description of and link to IE Tab in the "Silverlight or Active X Controls in Firefox" section above. 

Pop-Up Blocker in Chrome

Google Chrome automatically prevents pop-ups . To see blocked pop-ups in Chrome, click the icon on the browser toolbar. To always see pop-ups for ctimls.com if a pup-up has already been blocked, click the icon and select "Always show pop-ups from ctimls.com". The site will be added to the Exceptions list, which you can manage in the Content Settings dialog (as described below).

To add "ctimls.com" as an exception so any of its pop-ups will not be blocked, click the Chrome Menu icon on the browser toolbar > select Settings > click Show advanced settings (at the bottom) > in the "Privacy" section, click the Content Settings button > in the "Pop-ups" section, select "Do not allow any site to show Pop-ups (recommended)" > click Manage exceptions > enter "ctimls.com" under Hostname Pattern > select "Allow" as the Behavior > click OK > X to Close. 

In older versions of Chrome, click the Wrench icon in  Chrome's address bar > select Options (Preferences on a Mac) > click "Under the hood" tab > select "Content Settings" button under "Privacy" > select Pop-up under "Features" > click the Exceptions button > click the Add button and enter "ctimls.com" under Pattern > OK > Close. 

▲ Back to the TOPIC Index at the top of this web page 

Enable Adobe Flash Player Plug-in in Chrome

To set Chrome to use the Adobe Flash Player plug-in (for videos such as Navigator Web tutorial video):
  1. Open the Chrome browser
  2. Open a New Tab (or press Ctrl+T on the keyboard)
  3. In the omnibox at the top, type  chrome:plugins  and press the enter key
  4. Scroll down to "Adobe Flash Player" and immediately beneath click Enable  and check "Always Allowed"
  5. Close the Plug-ins screen and refresh the browser (click the F5 key).

For help installing Flash Player, see Adobe Flash Player Help: Download, Install, Enable and Verify (in the Related Articles and Internet Links at the bottom of this webpage). 

Chrome Frequently Crashes

According to Google, try closing older tabs, inactive tabs, tabs with lots of graphics, or other open programs on your computer to free up more memory. If you are accessing the Internet wirelessly, you also may try improving signal strength by moving your computer closer to your Internet router, or connect you computer to the router using a wire.

Reset Chrome to its Original Defaults  (reprinted from Chrome help)

Programs that you install can change your Chrome settings without your knowledge. You may see additional extensions and toolbars or a different search engine. Resetting your browser settings will reset the unwanted changes caused by installing other programs. However, your saved bookmarks and passwords will not be cleared or changed.

To Reset your Chrome browser settings:

  1. Click the Chrome menu  on the browser toolbar.
  2. Select Settings.
  3. Click Show advanced settings and find the "Reset browser settings” section.
  4. Click Reset browser settings.
  5. In the dialog that appears, click Reset. (To view Google's reset message, click on this image )

Resetting your Chrome browser settings will impact the settings below:

If you’re still having issues you may have a program installed on your operating system that is updating your Google Chrome settings. Learn more about programs that cause unwanted settings changes.

Get help from the Chrome Help Forum

If resetting your browser settings doesn't work, you can get more help in the Chrome Help Forum. Below is a list of programs that consistently cause changes to Chrome settings. Click a link to go the appropriate forum.

If you don't see your program listed, visit Homepage, Search engine or Chrome settings changed for possible help.

Uninstall Google Chrome 

Uninstall Chrome in Windows

You can use Windows' Control Panel to remove Chrome, or follow these steps:

  1. Ensure that you have another browser installed, or a browser install file downloaded in your computer and ready to install.
  2. Go to Start > All Programs > Google Chrome > Uninstall Google Chrome.
  3. If you want to delete your user profile information (such as your browser preferences, bookmarks, and history), select the "Also delete browser data" checkbox.
  4. Select the default browser you'd like to use.
  5. Click OK in the confirmation prompt.

If the normal uninstall methods fail, manually uninstall Chrome in Windows as follows:

  1. Ensure that extensions are displayed for your files. Here's how:
    • Go to the Start menu > Control Panel
    • Double-click Folder Options
    • Click View
    • Un-check "Hide extensions for known file types"
  2. Right-click this link to a file named remove.txt 
  3. Click Save Link as (or Save Target as), select "All files" as the file type, and rename the file to remove.reg when you Save (i.e., change the file extension from txt to reg). 
  4. Exit Google Chrome completely.
  5. Double-click on the remove.reg file that you saved onto your computer (usually on the Windows desktop).
  6. In the confirmation window, click Yes.
  7. Click OK.
  8. Go to the Start menu > Run.
  9. Enter one of the following commands in the text field, depending on your operating system:
    • Windows XP:%USERPROFILE%\Local Settings\Application Data\Google
    • Windows Vista or 7: %LOCALAPPDATA%\Google
  10. Delete the Chrome folder in the directory that opens.

▲ Back to the TOPIC Index at the top of this web page 

Uninstall Chrome in Mac OS X

  1. Go to the folder containing Google Chrome.
  2. Drag Google Chrome to the Trash icon in the Dock. You'll need administrative rights if it's installed in your Applications folder. To remove the Google Chrome icon from your Dock, simply drag it out of the Dock with your mouse.

Safari Browser Issues

Empty Browsing Cache and Cookies in Safari on Mac

Open Safari to display the Safari Menu Bar

To empty the cache of webpage data saved by Safari 7 and later:

  1. Click the word Safari in the browser's top menu 
  2. Select Preferences  (click to see image)
  3. Select the Advanced tab (click to see Safari 7 image)  
  4. Check "Show Develop menu in menu bar" (click to see image)
  5. Select Develop in Safari menu bar:  
  6. Click on "Empty Caches"  (click to see image)
  7. Close Safari and then re-open the browser. 

To empty the cache of web page data saved by Safari 6 and earlier:

  1. Click the word Safari in the browser's top menu
  2. Select "Empty cache..."
  3. Click the "Empty" button to confirm
  4. Close Safari and then re-open the browser. 

To remove cookies and all other data saved by websites in Safari:

  1. Click the word Safari in the browser's top menu and select Preferences...
  2. Select the Privacy tab in Safari 7 or Safari 8
  3. Either click the "Remove All Website Data" button, or, to select and remove data for a specific website , click the Details button, select the specific website (such as ctimls.com), and click the Remove button 
  4. Close Safari and then re-open the browser. 

To reset Safari 7 to its original defaults:

  1. Click the word Safari in the browser's top menu and select "Reset Safari..."
  2.  Un-check any items you do not wish to remove (see note and warning below). 
     
    • Note: The following items may contain damaged files that could interfere with CTI Navigator Web. Therefore, at a minimum, these items should remain checked so their data is cleared when you click the Reset button:
      • Clear History 
      • Remove all webpage preview images
      • Empty the cache (or "Remove all website data")
      • Remove all cookies
      • Close all Safari windows
      • Reset all location warnings.
    • Warning: Reset cannot be undone.
  3. Click the Reset button
  4. Close Safari (if it doesn't close automatically) and then re-open it.

Safari 8 Note: "Reset Safari" has been replaced with "Clear History and Website Data" in Safari's drop-down menu (click here for Safari 8 Menu image).

Pop-Up Blocker in Safari on Mac

To disable the Pop-up-Up Blocker in Safari 6 later:

  1. Open Safari
  2. Click Safari in the browser's top menu (next to the Apple icon)
  3. Under Safari select Preferences  (click to see image)
  4. Select the Security tab
  5. Beside "Web Content", un-check “Block pop-up windows” (click to see image) 

To disable the Pop-Up Blocker in Safari 5 and older: open Safari, select Edit in the toolbar, and un-check "Block Pup-Up Windows." A shortcut is to hold down the Control+Shift key and press the "K" key on your keyboard.

▲ Back to the TOPIC Index at the top of this web page 

Silverlight in Safari on Mac

To verify that the Silverlight browser plug-in (used to run CTI Navigator Web) is installed in Safari, click Help and select "Installed Plugins" in the top menu of the browser. 

To set Safari (6.1 and later) to allow the Silverlight plug-in to run in unrestricted mode specifically on CTI’s website for your MLS (which is needed to support CTI Navigator Web functions performed in the browser on your computer and prevent "System Exception" errors), click here for details and screen shots;  or follow these basic steps: open the CTI Navigator Web sign in page in Safari > click Safari (beside the apple icon) in the browser menu > select Preferences > Security > un-check "block pop-up windows" > beside "Internet plug-ins" check "Allow Plug-ins", then click the "Manage Website Settings" button > on the left pane, click Silverlight > on the right pane, select the CTI Navigator website address for your MLS > click the button to the right of that address and select "Run in Unsafe Mode" > click Done > click the button to Trust the CTI Navigator website to run Silverlight in unsafe mode. You may need to close then re-open all Safari screens for this change to take effect.

To troubleshoot problems using Silverlight in Safari, see "Fix Silverlight in Safari (or Firefox or Chrome) on a Mac" (also in the related articles at the end of this web page). 

To uninstall Silverlight on an Apple Mac:
  • Close all browser screens
  • Browse to the hard drive where Silverlight is installed
  • Select Library > Internet Plug-ins
  • Click on the Silverlight plug-in and drag it to Trash
  • Empty Trash.

Enable Adobe Flash Player in Safari on Mac

To enable the Adobe Flash Player plug-in in Safari on a Mac:

  1. Open a website that uses Flash (such as "http://get.adobe.com/flashplayer/")
  2. Click the word Safari in the browser's top menu and select Preferences...
  3. Select the Privacy tab
  4. Beside "Internet Plug-ins:"
    • in Safari 7 or 8, check "Allow Plug-ins" and click the "Manage Website Settings..." button 
    • in Safari 6 and earlier, check "Allow Java", check "Allow all other plug-ins", and click the "Manage Website Settings..." button
  5. On the left, select "Adobe Flash Player", and on the right click the button and select "Allow"

Click here for Adobe Help enabling Flash Player for Safari .

Click here for help installing and verifying that Flash Player is installed and operating properly in Safari. For detailed help installing Flash Player in Mac OS, click here.

Safari on Windows

Apple apparently abandoned development for Safari on Windows starting with the release of Safari version 6.0 (in July 2012). The last version of Safari for Windows is 5.1.7 (which was released May 2012). Safari version 5.1.7 for Windows can be downloaded from Apple here (as long as it is supported). 

▲ Back to the top of this web page 

Non Browser-Specific Errors

For "System Exception..." errors in CTI Navigator Web, close all browser screens and then re-open CTI Navigator Web. If the same error re-occurs, clear your browser's history/cache of stored web usage data (see Internet Explorer , Firefox, Chrome, or Safari above). Then close all browser screens, and re-open CTI Navigator Web. If Silverlight is installed, enabled, and the browser's temporary Internet browsing files have been completely cleared, but Silverlight does not work properly in any browser on this computer, Un-install Silverlight and then install the latest version.

On an Apple Mac, click here for instructions to un-restrict Silverlight specifically for your MLS website.

For more detailed instructions to fix System Exception errors, see Fix Silverlight Issues.

If the System Exception error persists, or you would like additional assistance:

  1. Click the "Show Details" button on the error screen
  2. Click the Copy button
  3. Open your personal email program:
    • click in the body of a new message and paste the error details
    • state what function you were using or attempted to use when the error occurred (such as sign-in, search, print, etc.)
    • indicate whether you computer is Windows or Mac
    • name the browser in which you are running Navigator (Internet Explorer, Chrome, Firefox, or Safari)
    • include your contact information
    • email this information to ctisupport@ctimls.com.

If you do not receive a reply to an email support request within a few business hours, or if you need immediate support after sending this information, contact CTI Technical Support (click this link for details, or phone 1-800-533-1031) during weekday business hours.

Active X error

To fix an "Active X" error that appears when you click on a Web-link, disable or configure your Internet pop-up blocker to allow pop-ups on the desired website. For instructions on disabling pop-up blockers, see the related article, "Disable Common Pop-Up Blockers". 

For more information about other possible causes of Active X errors, see the related article, "Fix Active X error".

Class Does Not Support Automation or Expected Interface error

To fix an "Class does not support Automation or Expected Interface" error that appears when you click on a Web-link in Windows, close all browser screens and re-register the actXprxy.dll file in your Windows\System32.

  1. Click on Start
  2. In Windows 7 or Vista:
    • type cmd  in the Search box
    • Right-click on cmd.exe and choose “Run as administrator
    In Windows XP
    • select Run > type cmd  in the Open box > click OK
  3. Type Regsvr32 actxprxy.dll  and press Enter
  4. Click Ok to close the "DllRegisterServer in actxprxy.dll succeeded" screen.

If re-registering actxprxy.dll does not resolve the error, follow the instructions above to re-register all Internet Explorer original files and to reset your version of Internet Explorer. This should also reset Internet connectivity components in Windows, regardless of which browser is set as the default. (See the warning note before re-setting Internet Explorer.)

Subscript Out of Range error

To fix a "Subscript Out of Range" error that appears when you click on a Web-link in CTI Navigator, follow the instructions on the Fix Subscript Out of Range error web page. 

Other Errors

For detailed steps to identify and correct most known causes of Firefox no longer working properly, see "Standard Diagnostic Steps to Fix Firefox" by the Mozilla organization. These are summarized in the General Diagnostics for Firefox section above. 

For other errors, see CTI's Instructions to Fix Errors when using CTI Navigator web page. 

▲ Back to the TOPIC Index at the top of this web page

Disclaimer Note. Please be advised that CTI does not accept any responsibility for software you download, or for information provided about settings or software not produced by CTI (see "CTI Disclaimers" in the Related Articles below).


Related Articles and Internet links:

▲ Return to the top of this web page

To return to CTI's menu of Instructions to Fix Errors or Troubleshoot Problems, click here, or use the back arrow at the top of your Internet browser. 

To go directly to CTI's on-line menu of Help and Tutorials for CTI Navigator, click here .

 

rev.  12.05.2014